d2jsp
d2jsp Forums > Computer Hardware Discussion > Misc Computer Help > Gpu No Display Monitor
Add Reply New Topic New Poll
mason1989
#1 Jan 24 2020 04:33pm
Group: Member
Posts: 14
Joined: Jan 3 2019
Gold: 0.00
Alright so I've been using i5 3570k 16gb ddr3 ram 500w psu and a GTX960 2gb (gigabyte ga-z77x-d3h motherboard) for the last 2-3 years.
my friend bought a new graphics card so he gave me his functioning rx 570 4gb.
I turned the power off and the PSU switch off and took out the old GPU and slotted in rx 570 and connected pci-e 6 pin. Now when I booted up the pc, theres a 1 long beep and 2 short beeps and hear the windows logging in sound from headset but no display. I searched the beep codes and 1 long beep and 2 short beeps means its a graphics card.
Now I searched online forums and they suggest to check my bios to see if its a legacy or uefi and try updating bios (I didn't update for the last 3 years..) so I connect dvi-d to my motherboard to use the intel hd 4000 and it shows no display.. and the same beeps occur. Now I have no working display...As of right now I am trying to restart cmos battery and plug out cables from the wall, plug out psu and leave it for 5 min to see if I get display back. Has anyone had similar problems like this occur when placing new graphics card?
Ghot
#2 Jan 24 2020 04:43pm
Group: Member
Posts: 97,473
Joined: Apr 25 2006
Gold: 10,175.00
Try re-seating the RAM. Dust in the RAM slots or just jiggling it a bit, can cause no display.

/e You should probably uninstall the Nvidia driver....then switch the cards. But check the RAM situation first.

This post was edited by Ghot on Jan 24 2020 04:45pm
mason1989
#3 Jan 24 2020 04:45pm
Group: Member
Posts: 14
Joined: Jan 3 2019
Gold: 0.00
ok, took out the psu and cmos battery. waiting few minutes and will do reseat the ram sticks
Go Back To Misc Computer Help Topic List
Add Reply New Topic New Poll