d2jsp
d2jsp Forums > General Chat > Car Audio > Rip
Add Reply New Topic New Poll
Zpot
#1 May 26 2018 06:32pm
Group: Member
Posts: 7,715
Joined: Jun 1 2012
Gold: 24,614.30
Audiopipe APCL1500D1 went into protect mode today (been running it daily for about 2 years on 2 12D4 Type R's at 1 ohm). Used a DMM to check voltages, 14.0 V at the +/- at the battery, 6.2 V at the +/- terminals at the amp, 1.2 ohm resistance at the +/- speaker inputs on the amp, and less than 0.05 ohm variance at the sub +/- terminals. Ground is clean, remote turn on voltage is proper, fuses look good. I'm thinking a budget beater amp can only go so far and the amp itself is toasted.
0x5A
#2 Jun 5 2018 04:49pm
Group: Member
Posts: 38
Joined: Jun 3 2018
Gold: 55.69
Pls no111
kookymunsta309
#3 Jun 13 2018 03:43pm
Group: Member
Posts: 6,369
Joined: Jul 22 2009
Gold: 2.45
Shit happens man, 2 years on a budget amp like that is good. Upgrade to an AP 3k LOL
HardCoreGuyHere
#4 Jun 14 2018 05:47pm
Group: Member
Posts: 2,012
Joined: Sep 19 2017
Gold: 0.00
i abused my apcl1800 at half ohm for years and no issues. voltage saw as low as high 10s too lol
Zpot
#5 Jun 18 2018 01:06am
Group: Member
Posts: 7,715
Joined: Jun 1 2012
Gold: 24,614.30
went to check my ground wire and the connection point at the chassis looked like the god damn statue of liberty. Cleaned it up and it looks good now.
naTodd
#6 Jun 29 2018 10:17am
Group: Member
Posts: 101
Joined: Apr 15 2005
Gold: 0.00
Upgrade time
Go Back To Car Audio Topic List
Add Reply New Topic New Poll